User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Flashers and Break lights dont work

  1. #1
    Junior Member
    Join Date
    Jul 2008
    Location
    Oceanside
    Posts
    31

    Branch
    Marine Corps
    Status
    Serving
    Served
    2006 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Flashers and Break lights dont work

    i have a problem i have a 2003 tj and everything works but the flashers and break lights. i checked the fuses in the glove box those are fine. what i think it is are the releys but i cant find them and i checked the fuses under the hood. can someone tell me were they are at.

  2. #2
    The Copenhagen Kid MaineJeepah's Avatar
    Join Date
    May 2009
    Location
    Beaufort
    Posts
    806

    Branch
    Marine Corps
    Status
    Serving
    Served
    2008 to Present

    Closest Installation

    MCAS Beaufort
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    The relays are under the hood with the fuses, they will look like this...

    "Look, when I was a kid, I inhaled frequently. That was the point." -Barack Obama

  3. #3
    Junior Member WILLTAKE's Avatar
    Join Date
    Dec 2008
    Location
    BETHEL
    Posts
    99

    Branch
    Army Reserves
    Status
    Serving
    Served
    1999 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    If you have taken off the rear tail lights recently make sure the bolts are on tight since they ground your lights. A friend had a similar problem on his 99 and after lots of wire checking it turned out to just be a loose screw
    A simple misunderstanding gets a lot less simple when you add choppers and a SWAT team.

  4. #4
    Back to 1 Jeep... for now rroadkilll's Avatar
    Join Date
    Jul 2008
    Location
    Hertford NC
    Posts
    1,567

    Branch
    Coast Guard
    Status
    Serving
    Served
    2005 to Present

    Closest Installation

    AIRSTA Elizabeth City
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I had a (kinda) same problem... it was the blinker switch thingy in the steering column...

  5. #5
    Land Squid Jeffb_79's Avatar
    Join Date
    May 2008
    Location
    Fairfax, VA
    Posts
    3,593

    Branch
    Navy
    Status
    Served
    Served
    1999 to 2010

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    The blinker relay is in the steering column. Since you're having issues with brake lights and blinkers it could be something else though.

  6. #6
    The Copenhagen Kid MaineJeepah's Avatar
    Join Date
    May 2009
    Location
    Beaufort
    Posts
    806

    Branch
    Marine Corps
    Status
    Serving
    Served
    2008 to Present

    Closest Installation

    MCAS Beaufort
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Jeffb_79 View Post
    The blinker relay is in the steering column. Since you're having issues with brake lights and blinkers it could be something else though.

    Way to make me look stupid lol
    "Look, when I was a kid, I inhaled frequently. That was the point." -Barack Obama

  7. #7
    Land Squid Jeffb_79's Avatar
    Join Date
    May 2008
    Location
    Fairfax, VA
    Posts
    3,593

    Branch
    Navy
    Status
    Served
    Served
    1999 to 2010

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by MaineJeepah View Post
    Way to make me look stupid lol
    Haha... you'll be ok

  8. #8
    Land Squid Jeffb_79's Avatar
    Join Date
    May 2008
    Location
    Fairfax, VA
    Posts
    3,593

    Branch
    Navy
    Status
    Served
    Served
    1999 to 2010

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Do your hazards work?

    edit: also, start researching the brake switch. it looks like both the brakes and signals route through it.
    http://www.justanswer.com/questions/...nals-dont-work
    http://wiki.answers.com/Q/Where_is_t...itch_1999_Jeep
    Last edited by Jeffb_79; 09-09-2009 at 22:00.

  9. #9
    The Copenhagen Kid MaineJeepah's Avatar
    Join Date
    May 2009
    Location
    Beaufort
    Posts
    806

    Branch
    Marine Corps
    Status
    Serving
    Served
    2008 to Present

    Closest Installation

    MCAS Beaufort
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Jeffb_79 View Post
    Haha... you'll be ok


    Hahaha yeah I know, you see i posted our record breaking attendance picture up..?
    "Look, when I was a kid, I inhaled frequently. That was the point." -Barack Obama

  10. #10
    Land Squid Jeffb_79's Avatar
    Join Date
    May 2008
    Location
    Fairfax, VA
    Posts
    3,593

    Branch
    Navy
    Status
    Served
    Served
    1999 to 2010

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by MaineJeepah View Post
    Hahaha yeah I know, you see i posted our record breaking attendance picture up..?
    Yeah... that was probably the most awesomist m&g ever. I'm surprised they had room for us all in there.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]