User Tag List

Results 1 to 5 of 5

Thread: Evap Control Malfunction

  1. #1
    Newbie Red2's Avatar
    Join Date
    Aug 2009
    Location
    Fort Knox
    Posts
    25

    Branch
    Army
    Status
    Serving
    Served
    1996 to Present

    Closest Installation

    Fort Knox
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Evap Control Malfunction

    Hello everyone,

    I have a 08 JK and have had trouble with the check engine light. I have had the gascap replaced, the EVAP canister replaced and it is still throwing OBD code, P0440. The dealership is at a loss, and I dont know what to do, any suggestions?

    Also I have recently bought a hypertech programmer and the thing works great, but is it common for a multi purpose and multi vehicle style programmer to throw code that dont exsist for Jeep (i.e. U140E and C2202)?

    Thanks for your help
    If you aint CAV, you aint $h!


  2. #2
    on top, usually
    Join Date
    Jan 2009
    Location
    Momence
    Posts
    2,460

    Branch
    Navy
    Status
    Serving
    Served
    2002 to 2010

    Closest Installation

    Fort Leonard Wood
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    lemon law it, ive seen a couple JK's get lemon'd recently.

  3. #3
    Junior Member cphill209's Avatar
    Join Date
    Jan 2009
    Location
    Dixon
    Posts
    400

    Branch
    Army
    Status
    Serving
    Served
    1993 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Red2 View Post
    Hello everyone,

    I have a 08 JK and have had trouble with the check engine light. I have had the gascap replaced, the EVAP canister replaced and it is still throwing OBD code, P0440. The dealership is at a loss, and I dont know what to do, any suggestions?

    Also I have recently bought a hypertech programmer and the thing works great, but is it common for a multi purpose and multi vehicle style programmer to throw code that dont exsist for Jeep (i.e. U140E and C2202)?

    Thanks for your help
    I ran in to the same problem last summer, I had found I had bumped the canister on a trail run. I wiggled some hoses and it went away. Now 7 months later it has started throwing the gas cap error code again. Not sure if it the same problem or not yet. Might check the hose and make sure theirs no holes or bad conections at both ends.
    07 JK 2 DR Rubicon, RTI Score 673, 32's TereFlex 2.5 lift with shocks ,1 inch M.O.R.E Body Lift, Custom Bumper By Fred and Dave, and Raingler nets & grips , CB CH 4

    With out soldier sacrifice America would not be here today. Soldier on Hooah!!!

    http://www.wheelersforthewounded.com/index.htm

    http://www.facebook.com/album.php?ai...e.php?ref=home

    http://campmj.com/

  4. #4
    MODERATOR warrior's Avatar
    Join Date
    Jun 2009
    Location
    USA
    Posts
    3,810

    Branch
    Army
    Status
    Retired
    Served
    1965 to 1968

    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Last edited by warrior; 03-01-2010 at 19:23.
    If you don't give up---You will never fail.



    8th Combat Engineers (Sapper) (Vietnam 66)


  5. #5
    Hard Coal, Hard Core Dragline's Avatar
    Join Date
    Jan 2008
    Location
    Richmond, VA
    Posts
    607

    Branch
    Air Force Reserves
    Status
    Retired
    Served
    1978 to 2000

    Closest Installation

    Fort Lee
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Red2 View Post
    Hello everyone,

    I have a 08 JK and have had trouble with the check engine light. I have had the gascap replaced, the EVAP canister replaced and it is still throwing OBD code, P0440. The dealership is at a loss, and I dont know what to do, any suggestions?

    Also I have recently bought a hypertech programmer and the thing works great, but is it common for a multi purpose and multi vehicle style programmer to throw code that dont exsist for Jeep (i.e. U140E and C2202)?

    Thanks for your help
    As for the P0440, keep after the dealership and get a Chyrsler rep involved...

    Found this info, don't know if it will help you but talks to a tuner?
    http://www.lxforums.com/board/showthread.php?p=2554066
    U140E-IMPLAUSIBLE VEHICLE CONFIGURATION DATA RECEIVED

    U140E - if you swapped modules from another vehicle, you would get this code. i have a feeling there's more to this story. what were the conditions when this issue first occured? any work done to the car lately?

    Found this @ https://www.superchips.com/forum/vie...php?f=7&t=5335
    After updating my tuner to database 273 and tuning my truck, I checked for codes and had 5: C2202 - Original VIN Mismatch Missing

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]