User Tag List

Results 1 to 3 of 3

Thread: TJ woes

  1. #1
    The Little TJ That Did
    Join Date
    Feb 2009
    Location
    Fort Belvoir
    Posts
    129

    Branch
    Army
    Status
    Serving
    Served
    2000 to Present

    Closest Installation

    Fort Belvoir
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default TJ woes

    I have a 01 Tj 4.0, I am currently having problems with it stumbling during acceleration. I have checked my cam sensor, replaced my fuel pump, replaced the coil pack, replaced the ASD and the fuel pump relay. The plugs and wires are less than 3 months old,and a good air cleaner. I thought that it was bad gas when I replaced the fuel pump I cleaned the inside of the tank. I am at a loss. Oh yea no check engine light on.
    any help would be great.
    My budget boosted TJ went where the Grand Cherokee with a 6 in long arm lift wouldn't

  2. #2
    Experienced General Ass
    Join Date
    Apr 2009
    Location
    Fort Benning
    Posts
    790

    Branch
    Air Force
    Status
    Served
    Served
    1998 to 2002

    Closest Installation

    Fort Benning
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I will say this before someone else does and pisses you off. There are no wires.

    As posted, we put a new cam sensor on it, new coil pack rail and then the old back on to be sure, fuel pump, relays move around, fuel pressure checked.

    The problem is not consistent, it come and goes. I thought od the crank sensor but unsure. The crank sensor is the last thing electrical. The exhaust has been opened up to see if there is any improvement but was acting good at the time. I would think the CAT would show different signs like to power consistently, Jeep runs great when other times. CAT was checked for before and after temps and was normal. Injectors would not be it b/c all 6 would not intermittently go bad.

    So does anyone have an off the wall solution that has been experienced. I know a little about cars and am ok at trouble shooting but we could use some fresh input.
    GET ER UNDONE

  3. #3
    That Guy afjeep's Avatar
    Join Date
    Jan 2008
    Location
    Valdosta
    Posts
    3,587

    Branch
    Air Force
    Status
    Serving
    Served
    2004 to Present

    Closest Installation

    Moody AFB
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)

    Default

    is it possible the timing is off. the CPS on what i would call the distributor shaft is affected by its position. if that nut holding it in the engine came lose somehow it coulda moved a little. when i was having issues with mine after i dropped a new engine in, that was it. it was off by a hair. and it was kinda intermittent. it doesnt sound exactly like it but i figured i'd throw it out there. good luck with it.
    2004 Rubi, Poison Spyder Bumper with Trail Stinger. Warn M8000 winch, Rock Krawler X-factor long arm 4 inch lift, 35x12.50x15 BFG KM2s on Procomp 8 inch steelies, Tom Woods Driveshaft, Poison Syder Full Roll Cage, Tuff Designs rear bumper/Tire carrier, MetalCloak Arched Tube Fenders with 6 Inch Flares, Flowmaster Hushpower Muffler, Vanco Big Disk Brake upgrade, Line-X'd tub and cage.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]