User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Engine oil pressure / RPM Low

  1. #1
    Junior Member up4it1023's Avatar
    Join Date
    Apr 2008
    Location
    Fort Drum (deployed)
    Posts
    57

    Branch
    Army
    Status
    Serving
    Served
    2001 to Present

    Closest Installation

    Fort Drum
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Engine oil pressure / RPM Low

    gotta '06 unlimited with 17K miles. seems like every time i push my clutch in when coming to a stop the engine rpms plummit way to low (around 250 rpm) for a split second, which in turn makes my engine oil pressure drop. now it seems that it only does this when my engine has been running for a while when its hot out. and by hot i mean over 100 (f'n texas heat lol). anyone know why?
    '06 unlimited
    l _____
    /l ,,,,[____],
    l-----L ()lllllll()-
    ()_)---()_)-o--)_)

  2. #2
    Senior Member SavageSun4x4's Avatar
    Join Date
    Jun 2010
    Location
    17 Oaks Ranch, Boerne, Texas
    Posts
    2,373

    Branch
    Army
    Status
    Retired
    Served
    1967 to 1994

    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hard for me to say, I have not come across that. That said I will do my best.

    Mechanical: INSPECT in and around the throttle body, checking springs and mechanical linkage for binding, missing or stretched spring etc. Maybe help to clean using carb cleaner and or WD 40. Remove the intake hose at the body. Have someone open and close throttle while you are viewing inside and out.

    ECM: Pull your POSITIVE battery connection leaving the NEGATIVE in place. If the positive is long enough or if not using a metal tool (screwdriver etc) make a connectin from the POSITIVE cable to the Negative cable/post. Do this a few times insuring you have a good connection. Now put it all back together and go for a drive. This will do several things. 1) it will discharge any latent voltage by grounding out everything to the frame and engine 2) this will also FORCE the computer by clearing all but the embedded tables, to use the OEM settings. It will then LEARN your/new driving habits, make altitude adjustments etc etc. It will do this over the next 50 start/stop cycles.

    I do this on any TJ/JK tuneup and do it to mine at least once a year or if I change locations such as a trip to a higher altitude etc.

    In short this is a 'hard reboot' in the computer world...

    If none of that works, let us know and maybe someone else has experienced this...
    Don

    '15 Jeep Unlimited Rubicon Hard Rock...OLD SCHOOL 6 Spd Manual Trans
    17 Oaks Ranch Companies LLC

    www.savagesun4x4.com

  3. #3
    Junior Member bassackwards's Avatar
    Join Date
    Aug 2009
    Location
    hampton
    Posts
    31

    Branch
    Navy
    Status
    Serving
    Served
    2005 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    on the oil press prob. i have a 94 xj with a 4.0 when im at idle my oil stayes about 20 when running over 40. i was told all the moter needs is 15 to 20 so? I have tryed everything diff. filter diff. oil nothing has changed it

  4. #4
    Rock Tamer burns jeepin's Avatar
    Join Date
    Apr 2009
    Location
    Enterprise
    Posts
    728

    Branch
    Army
    Status
    Serving
    Served
    2006 to Present

    Closest Installation

    Fort Riley
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    my Jeep does the same thing. I've been told it's the oil pressure sending unit but I haven't been able to replace it yet
    '01 TJ, D44s, Detroit, 37s, winch
    '08 JK, ARBs, 35s, winch

  5. #5
    Junior Member up4it1023's Avatar
    Join Date
    Apr 2008
    Location
    Fort Drum (deployed)
    Posts
    57

    Branch
    Army
    Status
    Serving
    Served
    2001 to Present

    Closest Installation

    Fort Drum
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    don i looked under the hood and everything is as it should look. i also did a 'hard reboot'. i'll just have to wait till tomorrow when it gets hot as that is the condition when i'm having the problem. i'll let ya know. thanks a bunch
    '06 unlimited
    l _____
    /l ,,,,[____],
    l-----L ()lllllll()-
    ()_)---()_)-o--)_)

  6. #6
    Oh, the possibilities! njmmarines's Avatar
    Join Date
    Aug 2008
    Location
    Dundee
    Posts
    16

    Branch
    Marine Corps
    Status
    Serving
    Served
    2005 to 2010

    Closest Installation

    Camp Pendleton
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    For that new of a Jeep with such low miles it doesnt sound right. Along with bassackwards' post, the 4.0L oil pressure does have a tendency to run about 20psi when idling which is normal but I dont like it running that low so I use a quart of Lucas oil stabalizer in mine and it will idle about 35-40psi which I am very happy with. I dont think that this really pertains to you but it is good knowledge. Is it throwing any codes?

  7. #7
    Land Squid Jeffb_79's Avatar
    Join Date
    May 2008
    Location
    Fairfax, VA
    Posts
    3,593

    Branch
    Navy
    Status
    Served
    Served
    1999 to 2010

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    With only 17k miles on it, I'd be at the dealership asking for a loaner jeep while they take care of this issue..... that's what you paid them for.

  8. #8
    Junior Member up4it1023's Avatar
    Join Date
    Apr 2008
    Location
    Fort Drum (deployed)
    Posts
    57

    Branch
    Army
    Status
    Serving
    Served
    2001 to Present

    Closest Installation

    Fort Drum
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    nope no codes at all and like said before it only happens when it is balls hot out and after i drive for say 15 min at that hot outside temp.
    '06 unlimited
    l _____
    /l ,,,,[____],
    l-----L ()lllllll()-
    ()_)---()_)-o--)_)

  9. #9
    Junior Member up4it1023's Avatar
    Join Date
    Apr 2008
    Location
    Fort Drum (deployed)
    Posts
    57

    Branch
    Army
    Status
    Serving
    Served
    2001 to Present

    Closest Installation

    Fort Drum
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    yeah well unfortunetly, with all the mod's and everything the factory warranty is probably void. it does have 17K miles on it but its a bit over 4 yrs old. so the 3yr/36,000 warranty has been gone for a while. this is the last hot summer i'll ever have since i'll be PCS'ing to fort drum in january
    '06 unlimited
    l _____
    /l ,,,,[____],
    l-----L ()lllllll()-
    ()_)---()_)-o--)_)

  10. #10
    Land Squid Jeffb_79's Avatar
    Join Date
    May 2008
    Location
    Fairfax, VA
    Posts
    3,593

    Branch
    Navy
    Status
    Served
    Served
    1999 to 2010

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Don't just assume because you have modified the vehicle you've voided the warranty. It's up to the dealer to prove your modifications caused the issue.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]