User Tag List

Results 1 to 10 of 10

Thread: Heater issue

  1. #1
    Senior Member ravengp's Avatar
    Join Date
    Sep 2009
    Location
    Houghton
    Posts
    1,680

    Branch
    Army
    Status
    Serving
    Served
    1995 to 2013

    Closest Installation

    Fort Drum
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)

    Default Heater issue

    Went to turn my heater on this morning and it won't come off of defrost. I turn the knob to the other positions but it still blows through the defrost vent.

    Is this an easy fix? Any ideas?
    Just because the road stops doesn't mean you have to!

  2. #2
    Zombie Slayer... JoeySnow70's Avatar
    Join Date
    Aug 2008
    Location
    Lawton
    Posts
    1,736

    Branch
    Army
    Status
    Retired
    Served
    1997 to Present

    Closest Installation

    Fort Sill
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Year model Jeep???

    I had similar situation in my TJ, Vaccum leak was the problem. There is a vac line under the battery box that goes to the vac accumulator. the line corroded becuse of of batt acid(I believe). I just replaced the messed up segment of vac line with some hose and problem solved....


    Hope it helps

  3. #3
    Administrator korisu56's Avatar
    Join Date
    Dec 2007
    Location
    Ft Gordon
    Posts
    11,020

    Branch
    Army
    Status
    Serving
    Served
    2003 to Present

    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    If its a YJ or CJ, I'd say check the cables to make sure that they haven't popped off. If its a TJ, I'd say pull off the knob to make sure the piece hasn't broken. Mine did in my old TJ. As a temp fix I switched it to the temp position cause it uses less stress and picked up another one.

  4. #4
    I am a chapter of one sincitycj's Avatar
    Join Date
    Dec 2007
    Location
    Las Vegas, Nv.
    Posts
    10,672

    Branch
    Army
    Status
    Served
    Served
    1985 to 1989

    Closest Installation

    Nellis AFB
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)

    Default

    For those who didn't bother to check his profile, he's driving a 01 Wrangler. Vacuum is most likely your culpret. Check the lines as stated before. If you don't find any leaks your blend door or control knob may be the problem.
    Last edited by sincitycj; 09-27-2010 at 17:07.
    Quote Originally Posted by usnavymitchells View Post
    went to google to see if I too was a dumb ass!!! Well actually I am.

    http://www.sincityrubs.com/

  5. #5
    Administrator korisu56's Avatar
    Join Date
    Dec 2007
    Location
    Ft Gordon
    Posts
    11,020

    Branch
    Army
    Status
    Serving
    Served
    2003 to Present

    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by sincitycj View Post
    For those who didn't bother to check his profile, he's driving a 97 Wrangler.
    haha, gee, i wonder who you're talking about.

  6. #6
    Zombie Slayer... JoeySnow70's Avatar
    Join Date
    Aug 2008
    Location
    Lawton
    Posts
    1,736

    Branch
    Army
    Status
    Retired
    Served
    1997 to Present

    Closest Installation

    Fort Sill
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by sincitycj View Post
    For those who didn't bother to check his profile, he's driving a 97 Wrangler..
    Yeah sure and go to all that trouble!!!! If you have a question and expect a good answer, the sensible thing is to give your rig info..... Or use the search option......

    According to his profile is an 01 TJ!!! so go figure!!!!

  7. #7
    Senior Member ravengp's Avatar
    Join Date
    Sep 2009
    Location
    Houghton
    Posts
    1,680

    Branch
    Army
    Status
    Serving
    Served
    1995 to 2013

    Closest Installation

    Fort Drum
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)

    Default

    At the risk of sounding stoopid (yeah, yeah I know "too late") how do I check for a vacuum leak? I checked the knobs and they are fine. I did pull apart the switch to find a piece of an old knob behind the panel (amazing what you find in a used jeep) but everything else looked ok. I have no idea how to check/fix the blend door or even where it is located.
    Just because the road stops doesn't mean you have to!

  8. #8
    I am a chapter of one sincitycj's Avatar
    Join Date
    Dec 2007
    Location
    Las Vegas, Nv.
    Posts
    10,672

    Branch
    Army
    Status
    Served
    Served
    1985 to 1989

    Closest Installation

    Nellis AFB
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by ravengp View Post
    At the risk of sounding stoopid (yeah, yeah I know "too late") how do I check for a vacuum leak? I checked the knobs and they are fine. I did pull apart the switch to find a piece of an old knob behind the panel (amazing what you find in a used jeep) but everything else looked ok. I have no idea how to check/fix the blend door or even where it is located.
    Vacuum leaks you can sometimes hear. As for the blend door, it's in behind the dash. I may have the FSM for a TJ at home. If I do I'll let you know.
    Quote Originally Posted by usnavymitchells View Post
    went to google to see if I too was a dumb ass!!! Well actually I am.

    http://www.sincityrubs.com/

  9. #9
    Senior Member ravengp's Avatar
    Join Date
    Sep 2009
    Location
    Houghton
    Posts
    1,680

    Branch
    Army
    Status
    Serving
    Served
    1995 to 2013

    Closest Installation

    Fort Drum
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)

    Default

    that would be cool. where do I check for the vacuum leak? I know I have one on the intake/exhaust side (haven't been able to find that one either) but I wouldn't know where to look for the heater.
    Just because the road stops doesn't mean you have to!

  10. #10
    I am a chapter of one sincitycj's Avatar
    Join Date
    Dec 2007
    Location
    Las Vegas, Nv.
    Posts
    10,672

    Branch
    Army
    Status
    Served
    Served
    1985 to 1989

    Closest Installation

    Nellis AFB
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)

    Default

    For the heater, I have no idea. Sorry but my old CJ works off of cables.
    Quote Originally Posted by usnavymitchells View Post
    went to google to see if I too was a dumb ass!!! Well actually I am.

    http://www.sincityrubs.com/

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]