User Tag List

Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: heater sucks!!

  1. #1
    Junior Member capitol kid's Avatar
    Join Date
    Oct 2010
    Location
    edgewood
    Posts
    60

    Branch
    Army
    Status
    Served
    Served
    1985 to 1992

    Closest Installation

    Aberdeen Proving Ground
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Army heater sucks!!

    This has been the one ongoing problem I have had with my 99 tj that is drivin me insane!
    My blower controls work perfectly on all speeds and the duct selector switch works as well, i.e defrost,vents hi n lo, but the problem is, I cant seem to get the damn heater to get "hot" and blow good hot air.I have replaced the blower resister,the fan switch,flushed the engine SEVERAL times,even pulled the heater hoses off and checked circulation by hooking a garden hose to it and checking that it was actually "circulating" through it. Have also replaced the t-stat.Only thing I have NOT done yet is replace the water pump.
    Have any of you tj owners been thru this problem? It is a 99 tj sahara,4.0 l w/ac.

  2. #2
    I am a chapter of one sincitycj's Avatar
    Join Date
    Dec 2007
    Location
    Las Vegas, Nv.
    Posts
    10,672

    Branch
    Army
    Status
    Served
    Served
    1985 to 1989

    Closest Installation

    Nellis AFB
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)

    Default

    Don't the TJs have a seperate valve to control the water going into the heater core? If so it sounds like that may not be opening. It is also a possability that your heater core is plugged, though I would think that flushing would help. When you flushed the engine did you throw the controls to hot?
    Quote Originally Posted by usnavymitchells View Post
    went to google to see if I too was a dumb ass!!! Well actually I am.

    http://www.sincityrubs.com/

  3. #3
    texast
    Join Date
    May 2009
    Location
    Ruther Glen
    Posts
    33

    Branch
    Air Force
    Status
    Retired
    Served
    1974 to 1994

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    capitol,
    I had the same problem with my wrangler where everything worked but it would not get hot. One of the techs i work with told me to drain the system and either put it on a slight incline(hill) or raise the front end up off the ground just enough to where when you refill it you can get all the air bubbles out. Once you refill it lower it back down, start it up and check the level. The coolant level might go down a little so while it is running top it off and put the cap back on. Let it run enough to bring it up to normal operating range then check your heat again. I hope this works for you, it did for me and my heater works really good now. Good luck.

  4. #4
    Newbie
    Join Date
    Jul 2010
    Location
    Colorado Springs
    Posts
    26

    Branch
    Army
    Status
    Served
    Served
    1989 to 1997

    Closest Installation

    Fort Carson
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    when you flushed the heater core, did you flush it in reverse of the normal flow? also, when you flushed it, did you put anything in it to loosen the gunk inside? (used microwaved bleach, set for 10 minutes, then flush reverse flow - alot of brown gunk came out). if so, where your core sits, the box could be filled with gunk (branches, dirt, etc) if clogged will cause it to blow cold.

  5. #5
    Senior Member jeepdreamer's Avatar
    Join Date
    Oct 2008
    Location
    Ft Myer, Va
    Posts
    9,116

    Branch
    Army
    Status
    Serving
    Served
    1991 to Present

    Closest Installation

    Fort Myer
    Mentioned
    94 Post(s)
    Tagged
    1 Thread(s)

    Default

    Just be glad you don't have a CJ...or God help you a YJ!! Everytime I used the "heater" in my YJ I felt like I was getting head from some 90 year old asthmatic that could only reach my ankle!

  6. #6
    She-Jeeping Jarhead LeafspringMARINE's Avatar
    Join Date
    Nov 2008
    Location
    Longview, TX
    Posts
    1,045

    Branch
    Marine Corps
    Status
    Served
    Served
    1993 to 1997

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by jeepdreamer View Post
    Just be glad you don't have a CJ...or God help you a YJ!! Everytime I used the "heater" in my YJ I felt like I was getting head from some 90 year old asthmatic that could only reach my ankle!
    BAWAAAHAAAHAAAHAAAHAHAAAAAAA !!!

    I'm glad you have admitted to getting head from a 90 year old asthmatic!!!!

    Funny stuff!! I have an 89 YJ - the heater is probably the best running and most reliable thing on the whole rig.
    Meghan - MY KID CAN PICK OFF YOUR HONORS STUDENT AT A CLICK AND A HALF !
    • Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same.
      Ronald Reagan

  7. #7
    MCLMM DevilDogSoldier's Avatar
    Join Date
    Oct 2009
    Location
    Lost-in-the-woods
    Posts
    466

    Branch
    Marine Corps
    Status
    Retired
    Served
    1990 to 2014

    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    I gotta agree, the heater in my YJ works so good, I can't get it to NOT put out heat.
    April 2014 Jeep of the Month



  8. #8
    I am a chapter of one sincitycj's Avatar
    Join Date
    Dec 2007
    Location
    Las Vegas, Nv.
    Posts
    10,672

    Branch
    Army
    Status
    Served
    Served
    1985 to 1989

    Closest Installation

    Nellis AFB
    Mentioned
    47 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by jeepdreamer View Post
    Just be glad you don't have a CJ...or God help you a YJ!! Everytime I used the "heater" in my YJ I felt like I was getting head from some 90 year old asthmatic that could only reach my ankle!
    Thanks for making me choke on my lunch. Too much info on your personal life. The heater in my CJ works fine, and I haven't even upgraded the fan yet.
    Quote Originally Posted by usnavymitchells View Post
    went to google to see if I too was a dumb ass!!! Well actually I am.

    http://www.sincityrubs.com/

  9. #9
    Bobble Head Jeeper trailsnail's Avatar
    Join Date
    Jan 2008
    Location
    Colorado Springs
    Posts
    4,637

    Branch
    Army
    Status
    Retired
    Served
    1991 to 2012

    Closest Installation

    Fort Carson
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds like the heater core is boogered up, but that's only my opinion.
    Sven
    Colorado Springs Chapter Calendar and News

    '04 Wrangler Rubi, 5.5" Extreme Duty LA, 35" Goodyear Duratrac's, Warn RC 9.0 (Sold - My life sucks)

  10. #10
    Administrator miljeep's Avatar
    Join Date
    Dec 2007
    Location
    Anchorage
    Posts
    10,370

    Branch
    Army
    Status
    Serving
    Served
    1997 to Present

    Closest Installation

    Fort Richardson
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by jeepdreamer View Post
    Just be glad you don't have a CJ...or God help you a YJ!! Everytime I used the "heater" in my YJ I felt like I was getting head from some 90 year old asthmatic that could only reach my ankle!
    Dude, you are too much. I laughed and had to read it to my wife. It was even funnier reading that out loud.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]