User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: ABS and ESP Light is on

  1. #1
    Frankenstein hillybillyjeep08's Avatar
    Join Date
    Apr 2009
    Location
    hohenfels
    Posts
    1,016

    Branch
    Army
    Status
    Served
    Served
    2006 to 2010

    Closest Installation

    Hohenfels
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default ABS and ESP Light is on

    Its been a while since I posted anything but I am still alive and kicking.

    I need some help. My ABS, ESP, and Brake light are on.

    It started about 3 months ago. My Left rear Caliper was sticking when towing a trailer empty or weighted. Then the lights started. Just the ABS and ESP light.
    I pulled the codes and it was reading No communication with rear left ABS sensor and no Communication with Rear Right ABS sensor.

    So I ordered abs sensors for the rear and calipers, pads, and rotors.

    Yesterday, I replaced the rear ABS sensors, Rear calipers, Pads and Rotors.

    Lights are still on and my code reader is giving me some weird numbers. Rear left sensor shows 8,000 RPM when sitting still. and Rear Right sensor shows 0 RPM when sitting still. I hooked up my multi-meter to the ABS control module to test the wires and they are fine.

    Also Left rear caliper still sticks. and yes I bled out the brakes all 4 calipers. and they are still spongy.

    Anyone have any ideas.

    Thanks.
    2013 Jeep 4-Door 33x12.50r16, 2.5" Rock Krawler Short Arm lift, Intake, Chip, LED Lights, Skid plates, and Poison Spyder diff covers.

    /l ,[____],
    l---L -OlllllllO-
    ()_)-()_)-o-)_)

    Women are like guns, keep one around long enough and you are going to want to shoot it.

    http://www.wranglerforum.com
    www.offroadpark-knuellwald.de
    http://www.quadratec.com
    http://www.offroadpark-langenaltheim.de/

  2. #2
    Senior Member HillBillE's Avatar
    Join Date
    Jan 2008
    Location
    Duluth, MN
    Posts
    13,892

    Branch
    Army
    Status
    Served
    Served
    1985 to 1998

    Closest Installation

    Fort McCoy
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)

    Default

    For the sticky caliper: Did you replace the rubber line?

    I have had them go bed inside, nothing visible. But they end up acting like a 'check valve' and make the caliper stick.

    One way to check, is to apply the brakes, if the caliper is stuck/sticking, open the bleed screw.

    If that solves the stuck caliper, then you have a bad flex hose.


    As long as the people remain armed,
    government knows that it cannot rule over the people by force.
    Those who stand in defiance of unconstitutional laws
    do so out of duty, honor, oath and love of country.


    "Certified Jeep Junky!"


  3. #3
    Frankenstein hillybillyjeep08's Avatar
    Join Date
    Apr 2009
    Location
    hohenfels
    Posts
    1,016

    Branch
    Army
    Status
    Served
    Served
    2006 to 2010

    Closest Installation

    Hohenfels
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    I replaced the brake line with the stainless steel ones.

    The ABS and ESP light is still on.

    Rear wheel sensors show a signal and show the RPM's of the tires. Between the right rear and left rear there is 1 RPM different. I cleaned the teeth off on the rear so the sensor has a better reading.

    My wife and I bled the brakes today for an hour and there is no air in the lines went through a bottle of fluid.

    Still no idea what is wrong with the Jeep.
    2013 Jeep 4-Door 33x12.50r16, 2.5" Rock Krawler Short Arm lift, Intake, Chip, LED Lights, Skid plates, and Poison Spyder diff covers.

    /l ,[____],
    l---L -OlllllllO-
    ()_)-()_)-o-)_)

    Women are like guns, keep one around long enough and you are going to want to shoot it.

    http://www.wranglerforum.com
    www.offroadpark-knuellwald.de
    http://www.quadratec.com
    http://www.offroadpark-langenaltheim.de/

  4. #4
    Senior Member jeepdreamer's Avatar
    Join Date
    Oct 2008
    Location
    Ft Myer, Va
    Posts
    8,972

    Branch
    Army
    Status
    Serving
    Served
    1991 to Present

    Closest Installation

    Fort Myer
    Mentioned
    78 Post(s)
    Tagged
    1 Thread(s)

    Default

    Stupid question but is your steering wheel centered? If it's off more than a few degrees it can cause some issues with ABS and ESP.

  5. #5
    Frankenstein hillybillyjeep08's Avatar
    Join Date
    Apr 2009
    Location
    hohenfels
    Posts
    1,016

    Branch
    Army
    Status
    Served
    Served
    2006 to 2010

    Closest Installation

    Hohenfels
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Had an alignment done last month and thought that would take care of the issue. That was the first thing I did.

    About to change the battery
    2013 Jeep 4-Door 33x12.50r16, 2.5" Rock Krawler Short Arm lift, Intake, Chip, LED Lights, Skid plates, and Poison Spyder diff covers.

    /l ,[____],
    l---L -OlllllllO-
    ()_)-()_)-o-)_)

    Women are like guns, keep one around long enough and you are going to want to shoot it.

    http://www.wranglerforum.com
    www.offroadpark-knuellwald.de
    http://www.quadratec.com
    http://www.offroadpark-langenaltheim.de/

  6. #6
    Senior Member jeepdreamer's Avatar
    Join Date
    Oct 2008
    Location
    Ft Myer, Va
    Posts
    8,972

    Branch
    Army
    Status
    Serving
    Served
    1991 to Present

    Closest Installation

    Fort Myer
    Mentioned
    78 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by hillybillyjeep08 View Post
    Had an alignment done last month and thought that would take care of the issue. That was the first thing I did.

    About to change the battery
    Is the wheel straight when you drive?
    What's the battery show on a multimeter?

  7. #7
    Frankenstein hillybillyjeep08's Avatar
    Join Date
    Apr 2009
    Location
    hohenfels
    Posts
    1,016

    Branch
    Army
    Status
    Served
    Served
    2006 to 2010

    Closest Installation

    Hohenfels
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yes the wheel is straight when I drive

    i also get a low system voltage

    bit the battery shows 11.95VDC and while driving I get between 13.5-14 VDC
    2013 Jeep 4-Door 33x12.50r16, 2.5" Rock Krawler Short Arm lift, Intake, Chip, LED Lights, Skid plates, and Poison Spyder diff covers.

    /l ,[____],
    l---L -OlllllllO-
    ()_)-()_)-o-)_)

    Women are like guns, keep one around long enough and you are going to want to shoot it.

    http://www.wranglerforum.com
    www.offroadpark-knuellwald.de
    http://www.quadratec.com
    http://www.offroadpark-langenaltheim.de/

  8. #8
    Senior Member jeepdreamer's Avatar
    Join Date
    Oct 2008
    Location
    Ft Myer, Va
    Posts
    8,972

    Branch
    Army
    Status
    Serving
    Served
    1991 to Present

    Closest Installation

    Fort Myer
    Mentioned
    78 Post(s)
    Tagged
    1 Thread(s)

    Default

    Hmm... Won't hurt to have the battery tested. It may have a dead/dying cell. But that probably isn't the cause of the ESP/ABS. It isn't impossible but just kinda unlikely.

  9. #9
    Frankenstein hillybillyjeep08's Avatar
    Join Date
    Apr 2009
    Location
    hohenfels
    Posts
    1,016

    Branch
    Army
    Status
    Served
    Served
    2006 to 2010

    Closest Installation

    Hohenfels
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Just put in a yellow top optima lights are still on but brakes are ten times better. Not getting the low voltage code anymore.
    2013 Jeep 4-Door 33x12.50r16, 2.5" Rock Krawler Short Arm lift, Intake, Chip, LED Lights, Skid plates, and Poison Spyder diff covers.

    /l ,[____],
    l---L -OlllllllO-
    ()_)-()_)-o-)_)

    Women are like guns, keep one around long enough and you are going to want to shoot it.

    http://www.wranglerforum.com
    www.offroadpark-knuellwald.de
    http://www.quadratec.com
    http://www.offroadpark-langenaltheim.de/

  10. #10
    Senior Member jeepdreamer's Avatar
    Join Date
    Oct 2008
    Location
    Ft Myer, Va
    Posts
    8,972

    Branch
    Army
    Status
    Serving
    Served
    1991 to Present

    Closest Installation

    Fort Myer
    Mentioned
    78 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by hillybillyjeep08 View Post
    Just put in a yellow top optima lights are still on but brakes are ten times better. Not getting the low voltage code anymore.
    Did you try clearing the codes?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]