User Tag List

Results 1 to 5 of 5

Thread: Finally got my XJ here..need some help...

  1. #1
    Indecisive servicemember medicbear's Avatar
    Join Date
    Jan 2009
    Location
    Clarkston
    Posts
    1,153

    Branch
    Army
    Status
    Serving
    Served
    2001 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Finally got my XJ here..need some help...

    Finally got my XJ down here from Mich. Now to get her runnin right again which i hope isnt gonna run me to much money... It sucks cause its a 96 but i got screwed into puttin a renix engine in it.. Which isnt bad i hear if i ever decide to stroke it out. But ive heard they can be harder to diagnose problems.. But i hear most problems with them stem from either a ground or vaccum problem.. Man i hear a lot of things.. Hoping to have it running good prior to opening day at ft scott, will be the first time wheeling with my wife and 10 month old... Quite excited...

    SO trying to figure out a rough idle that occasionally stalls, severe surging when overdrive is on, and oil pressure gauge that jumps round according to RPM and usually sits all the way to the right.... any ideas? got a pdf FSM to help me gonna get a multimeter to check grounds though i need to learn what im doin in that aspect not much electrically expirienced.

  2. #2
    No Mas Jeepalonie
    Join Date
    May 2008
    Location
    Clarksville
    Posts
    5,668

    Branch
    Army
    Status
    Serving
    Served
    1992 to Present

    Closest Installation

    Fort Campbell
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)

    Default

    try throttle position sensor
    Jeepless Again

    2008 Ford F150

  3. #3
    Indecisive servicemember medicbear's Avatar
    Join Date
    Jan 2009
    Location
    Clarkston
    Posts
    1,153

    Branch
    Army
    Status
    Serving
    Served
    2001 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    tried that no luck... im gonna start checkin grounds and the intake seals
    2001-2005 Air Force Medic, 2005-2006 Navy Corpsman, 2007-Present Army Medic/Chaplains Asst.

  4. #4
    Bobble Head Jeeper trailsnail's Avatar
    Join Date
    Jan 2008
    Location
    Colorado Springs
    Posts
    4,637

    Branch
    Army
    Status
    Retired
    Served
    1991 to 2012

    Closest Installation

    Fort Carson
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    If you just got it and haven't done anything to it, a good way to start is to give it a good tune up, and then see how it goes. Change plugs, wires, all fluids, distributor rotor cap and the stupid thing that spins inside, oil filter, air filter, fuel filter, etc. This way you know that it isn't any one of these as all can cause a vehicle to run not quite right. After that, when you know you have good fuel flow, good spark, and it's getting air, you may be able to narrow down a single problem. (this may not be the best way to diagnose a problem, but I like to do it whenever I get a new (old) car).
    Sven
    Colorado Springs Chapter Calendar and News

    '04 Wrangler Rubi, 5.5" Extreme Duty LA, 35" Goodyear Duratrac's, Warn RC 9.0 (Sold - My life sucks)

  5. #5
    Indecisive servicemember medicbear's Avatar
    Join Date
    Jan 2009
    Location
    Clarkston
    Posts
    1,153

    Branch
    Army
    Status
    Serving
    Served
    2001 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by trailsnail View Post
    If you just got it and haven't done anything to it, a good way to start is to give it a good tune up, and then see how it goes. Change plugs, wires, all fluids, distributor rotor cap and the stupid thing that spins inside, oil filter, air filter, fuel filter, etc. This way you know that it isn't any one of these as all can cause a vehicle to run not quite right. After that, when you know you have good fuel flow, good spark, and it's getting air, you may be able to narrow down a single problem. (this may not be the best way to diagnose a problem, but I like to do it whenever I get a new (old) car).
    He did ALL of that when we put it in new gaskets too... Tried the TPS, and one other part but couldnt remember what it was... The oil thing im thinkin is just the oil pressure sensor... IM gonna check the intake seals then the o2 sensors... What happend was threw a rod while driving so i dont know if maybe some how the 1st o2 sensor got taken out with it as well or somethin...
    2001-2005 Air Force Medic, 2005-2006 Navy Corpsman, 2007-Present Army Medic/Chaplains Asst.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]