User Tag List

Results 1 to 7 of 7

Thread: 1997 tj

  1. #1
    Lvl 10 terrydaktal's Avatar
    Join Date
    Feb 2009
    Location
    Virginia Beach
    Posts
    72

    Branch
    Navy
    Status
    Serving
    Served
    2008 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 1997 tj

    well i just bought a 1997 tj a couple of days ago and i was driving down the road and the airbag light turned on and all of the gages turned off and then about 5 minutes later the check engine light came on and then the small gages turned on and then the check engine light and the airbag light turned off and all of the gages started working again.?? any help would be greatly appreciated.

  2. #2
    Administrator korisu56's Avatar
    Join Date
    Dec 2007
    Location
    Ft Gordon
    Posts
    11,020

    Branch
    Army
    Status
    Serving
    Served
    2003 to Present

    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds freaky for sure. will be watching this thread to see what the experienced people say. sounds like an electrical restart though...

  3. #3
    Junior Member andy02's Avatar
    Join Date
    Feb 2009
    Location
    Spangdahlem
    Posts
    225

    Branch
    Air Force
    Status
    Serving
    Served
    2000 to Present

    Closest Installation

    Spangdahlem AB
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like the dash connection for the gauge cluster is loose. It is relatively common on TJ's. The fix is to take the gauge cluster out. You will find a multi-pin connector that connects the gauge cluster to the dash. Disconnect the multi-pin connector and make sure that all the connectors make solid contact. Use a jewelers screwdriver to adjust any that may be loose. Apply a little die-electric grease and re-connect the connector. Put the whole she-bang back together.

  4. #4
    Rock crawling Infidel BucketOKarma's Avatar
    Join Date
    Mar 2008
    Location
    Northfield
    Posts
    1,640

    Branch
    Army Reserves
    Status
    Serving
    Served
    2005 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by andy02 View Post
    Sounds like the dash connection for the gauge cluster is loose. It is relatively common on TJ's. The fix is to take the gauge cluster out. You will find a multi-pin connector that connects the gauge cluster to the dash. Disconnect the multi-pin connector and make sure that all the connectors make solid contact. Use a jewelers screwdriver to adjust any that may be loose. Apply a little die-electric grease and re-connect the connector. Put the whole she-bang back together.

    X2
    I had the same problem, did this and it stopped (sort-of) I do still get the airbag light sometimes, but everything else has been fine.
    - Shane

    2000 TJ 2.5L SE, 2" spacers and XJ springs up front, Crown-Vic springs in the rear, Edlebrock shocks, 33" Dayton M/Ts, JKS discos, SYE/CV shaft, Warn gastank skid, 4.88 gears ShrockWorks sliders, OX locker, Camo soundbar, and 04 Willys Edition front seats, still LOOKING FOR A MATCHING REAR SEAT.

    HeavyMetalConcepts.com

    CampMJ.com

    SISOffroad.com

  5. #5
    Gone Wheelin' beecee's Avatar
    Join Date
    Dec 2008
    Location
    Maryville
    Posts
    303

    Branch
    Air Force
    Status
    Retired
    Served
    1968 to 1988

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    What they said, and also remember, "It's a Jeep Thing, You wouldn't Understand". Every now and then my gas guage goes bonkers, I know it's 3/4 full, but after a few bounces on the rocks, it shows a 1/4 tank. Shut it down and re-start and it's back to 3/4. Sh*t Happens.
    Bill Collins
    USAF Retired
    Knoxville Wranglers
    Military Jeepers.com
    '04 TJ,
    '04 Ford F-150 w/5.4 Triton, Tow Rig,
    '08 Parker 14' trailer.

  6. #6
    Lvl 10 terrydaktal's Avatar
    Join Date
    Feb 2009
    Location
    Virginia Beach
    Posts
    72

    Branch
    Navy
    Status
    Serving
    Served
    2008 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    thanks for all your help i will have to try that one of these weekends

  7. #7
    Back to 1 Jeep... for now rroadkilll's Avatar
    Join Date
    Jul 2008
    Location
    Hertford NC
    Posts
    1,567

    Branch
    Coast Guard
    Status
    Serving
    Served
    2005 to Present

    Closest Installation

    AIRSTA Elizabeth City
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check out... www.dailydrivenTJ.com

    It's all TJ's... Ask there... Lots of good info!!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]