User Tag List

Results 1 to 9 of 9

Thread: fuel pressure issue

  1. #1
    That Guy RnEmOvr's Avatar
    Join Date
    Jul 2008
    Location
    El Paso
    Posts
    2,406

    Branch
    Army
    Status
    Serving
    Served
    2008 to Present

    Closest Installation

    Fort Bliss
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default fuel pressure issue

    having an odd problem with my fuel pressure, when i turn the pump on (either by key or by-passing the relay) i get about 20-25 PSI (using a fuel pressure gauge on the rail) and thats not enough to start the jeep, i can pour a small amount (1-2 tbl spoons) of fuel in the TB and the motor will start right up. but upon playing around i found that if i remove the fuel return line and place my finger over the port i will get the required 40 PSI. so i know my pump is good but what can i do to fix said issue? here is pic of my fuel rail as i dunno if the YJ rail is different then the TJ rail, the jeep is a 99 TJ but the 4.0 is from a 95 YJ using all TJ parts

    Just another lifted, locked and cut up TJ, Have Cummins, will tow

    Random Jeep Stuff

    My YouTube page

  2. #2
    Geländewagen Bigskyxj's Avatar
    Join Date
    Mar 2009
    Location
    Fort Iwrin
    Posts
    611

    Branch
    Army
    Status
    Serving
    Served
    2003 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I can't see the picture because I am currently on a GC, however going off of what you described I would say it is a faulty pressure regulator. That is all assuming you have the same setup that an XJ has for fuel pressure regulation. On an XJ the pressure regulator creates a restriction on the return side and therefore allows the pump to pressurize.
    Quote Originally Posted by sincitycj View Post
    I got a wave from a compass once. That was sure confusing. I didn't know if I should wave or barf.

    Be sure to check out the Germany Chapter Page:

    http://www.militaryjeepers.com/chapter/germany/index.shtml

  3. #3
    That Guy RnEmOvr's Avatar
    Join Date
    Jul 2008
    Location
    El Paso
    Posts
    2,406

    Branch
    Army
    Status
    Serving
    Served
    2008 to Present

    Closest Installation

    Fort Bliss
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    so there is a regulator on the pump as well?
    Just another lifted, locked and cut up TJ, Have Cummins, will tow

    Random Jeep Stuff

    My YouTube page

  4. #4
    Experienced General Ass
    Join Date
    Apr 2009
    Location
    Fort Benning
    Posts
    790

    Branch
    Air Force
    Status
    Served
    Served
    1998 to 2002

    Closest Installation

    Fort Benning
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Your problem is a fuel pressure regulator. There is two ways for it to be bad. Either it will have way to much fuel pressure or in your case not enough. It seems as if it is worn out and letting to much fuel back to tank. change it and you will be fine.

    By the way. That is some good trouble shooting you did.

  5. #5
    That Guy RnEmOvr's Avatar
    Join Date
    Jul 2008
    Location
    El Paso
    Posts
    2,406

    Branch
    Army
    Status
    Serving
    Served
    2008 to Present

    Closest Installation

    Fort Bliss
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok so after more research TJ motor dont have a return! that 2nd line should be going to my EVAP system, damn YJ motor throwing me all off.



    and hobby i hate asking for help so i do EVERYTHING i can think of before posting up, i have done even more trouble shooting then what meets the eye, i took about 10 different write ups to do my motor swap, and i went from a 99 2.5 to a 95 4.0 and got it all working with only 1 CEL and thats for a TPS then i did a full write up WITH part numbers,
    Just another lifted, locked and cut up TJ, Have Cummins, will tow

    Random Jeep Stuff

    My YouTube page

  6. #6
    That Guy RnEmOvr's Avatar
    Join Date
    Jul 2008
    Location
    El Paso
    Posts
    2,406

    Branch
    Army
    Status
    Serving
    Served
    2008 to Present

    Closest Installation

    Fort Bliss
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    so after some help from never monday on PBB i went and looked at my neighbors jeep (talking about a confused guy when i ask if i could open his hood and check vacume lines lol) after seeing how bad i had things off i rerouted them right, plugged the fuel return on the rail, and the jeep started right up (minus needing jump start) and it runs real smooth now :thumbsup:
    Just another lifted, locked and cut up TJ, Have Cummins, will tow

    Random Jeep Stuff

    My YouTube page

  7. #7
    Geländewagen Bigskyxj's Avatar
    Join Date
    Mar 2009
    Location
    Fort Iwrin
    Posts
    611

    Branch
    Army
    Status
    Serving
    Served
    2003 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ahh the old chinese troubleshooting trick.
    Quote Originally Posted by sincitycj View Post
    I got a wave from a compass once. That was sure confusing. I didn't know if I should wave or barf.

    Be sure to check out the Germany Chapter Page:

    http://www.militaryjeepers.com/chapter/germany/index.shtml

  8. #8
    DEATH BEFORE SHORE DUTY! SquiDMonkeY's Avatar
    Join Date
    Jun 2008
    Location
    Defiance
    Posts
    536

    Branch
    Navy
    Status
    Serving
    Served
    2000 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Bigskyxj View Post
    ahh the old chinese troubleshooting trick.
    hell i dont know about you're definition, but my wife (chinese) usually yells at me and says "FIX IT NOW!!" that's her chinese troubleshooting.

    and on another note, glad to see you got the jeep fixed!
    93 Cherokee Sport - Mine
    09 Dodge Journey - ComNavWife's

  9. #9
    Junior Member CJ2aChad's Avatar
    Join Date
    Jan 2009
    Location
    Springfield
    Posts
    389

    Branch
    Army
    Status
    Serving
    Served
    2004 to Present

    Closest Installation

    Fort Leonard Wood
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    haha we call this "doing an Air Force check"
    "Don't hold grudges because tomorrow my never happen!"

    "If you live for the weekend, you're missing out on 5/7ths of your life!"

    "Great danger lies in the notion that we can reason with evil"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]