User Tag List

Results 1 to 7 of 7

Thread: crankshaft or camshaft sensor?

  1. #1
    Looking for MUDD! BIGTRUX's Avatar
    Join Date
    Jun 2009
    Location
    Columbus
    Posts
    47

    Branch
    Army
    Status
    Serving
    Served
    1990 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default crankshaft or camshaft sensor?

    Ok guys well I took the TJ to auto zone. I know bad Idea but all I did was use thier code reader. here is what I got P1391 Crankshaft or camshaft sensor bad one is in my distribtior cap the other is on my transmission. like I said before she cranks over about 9 times and then runs good. unless I turn it over once then it fires right up. so how do I tell witch on it is? any ideas? I am thinking of just going to a junk yard and pulling off both and changing one at a time and see what happends, but what if I jut get more junk?.. any ideas on this would be great.
    97 Jeep Tj. sitting one 3 inches of lift 32/11.5 R15.
    4 Clanger with a 5 speed.

  2. #2
    Chiks=Trouble XJ=:) CrewDawg15/22's Avatar
    Join Date
    Apr 2009
    Location
    North Las Vegas
    Posts
    386

    Branch
    Air Force
    Status
    Serving
    Served
    1990 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    When I rebuilt the Engine in my cherokee I couldnt get it to crank ( I didnt take it apart and didnt know what the previous owner had messed with) so I went to AZ and picked up a Cam sensor and a Crank Sensor I want to say the cam sensor was only about 20 -30 bucks and is really not that hard to replace. The cranck sensor is not that hard either but those bolts are pretty tight and with the trans being so close to the fire wall it is a little tougher to replace and its about 60 bucks at AZ. I would suggest going with the cam sensor first.
    "If it Turns, Burns, Banks, and Rolls Crew Chiefs made it do it."

  3. #3
    Geländewagen Bigskyxj's Avatar
    Join Date
    Mar 2009
    Location
    Fort Iwrin
    Posts
    611

    Branch
    Army
    Status
    Serving
    Served
    2003 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    $100.00 says it is the crank sensor......make that $200.00
    Quote Originally Posted by sincitycj View Post
    I got a wave from a compass once. That was sure confusing. I didn't know if I should wave or barf.

    Be sure to check out the Germany Chapter Page:

    http://www.militaryjeepers.com/chapter/germany/index.shtml

  4. #4
    Mountain Valley Customs
    Join Date
    Jun 2008
    Location
    Millmont
    Posts
    1,438

    Branch
    Air Force
    Status
    Served
    Served
    1996 to 2005

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    We've had 7 Jeeps in last 3 weeks that have been a no start when hot. Basically, they would run fine, once they got to operating temp and you shut them off, they wouldn't start again until they cooled. All 7 were fixed by replacing the Crankshaft Position Sensor.
    Mountain Valley Customs www.mvcustoms.com 570.217.7284
    Specializing in 4x4s and custom fabrication


  5. #5
    Looking for MUDD! BIGTRUX's Avatar
    Join Date
    Jun 2009
    Location
    Columbus
    Posts
    47

    Branch
    Army
    Status
    Serving
    Served
    1990 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    wow ok well mine is running perfectly fine once it fires up. just has to turn over like 8 times to start. o just hit the key for a quick second and then hit it again and she is good. I am wondering if I got some gunk in the one on the tranny and it is just not reading? gonna pull it and clean it tonight then I try the one in the cap if that does not do the trick thanks guys.
    97 Jeep Tj. sitting one 3 inches of lift 32/11.5 R15.
    4 Clanger with a 5 speed.

  6. #6
    Geländewagen Bigskyxj's Avatar
    Join Date
    Mar 2009
    Location
    Fort Iwrin
    Posts
    611

    Branch
    Army
    Status
    Serving
    Served
    2003 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Clean the flywheel too if you can, the sensor reads off of the flywheel.
    Quote Originally Posted by sincitycj View Post
    I got a wave from a compass once. That was sure confusing. I didn't know if I should wave or barf.

    Be sure to check out the Germany Chapter Page:

    http://www.militaryjeepers.com/chapter/germany/index.shtml

  7. #7
    Looking for MUDD! BIGTRUX's Avatar
    Join Date
    Jun 2009
    Location
    Columbus
    Posts
    47

    Branch
    Army
    Status
    Serving
    Served
    1990 to Present

    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Well pulled off the sensor and found out that one of the wires got burned on the exaust and was shorting out on the body gave it some liquid tape and it is back to good as new now if only I could find the damn power steering sensor my check engine light would be gone for good. I know were it is just can't find one for sale.
    97 Jeep Tj. sitting one 3 inches of lift 32/11.5 R15.
    4 Clanger with a 5 speed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the MJ Supporter Membership for a little less than $0.06 a day and get more space, 2 MJ Stickers and no banners ads. [Check it out]